This project has moved and is read-only. For the latest updates, please go here.

sensenet install help needed

Apr 27, 2013 at 10:03 AM
I followed all the steps mentioned at
http://wiki.sensenet.com/index.php?title=How_to_install_Sense/Net_from_source_package_IIS_7.5_and_IIS_7.0

This is where I am bit confused.I was go from step 8. Run the install script: %sourceroot%\Deployment\InstallSenseNet.bat.
error:

2013-04-27 16:50:19.7547 ========================================
2013-04-27 16:50:19.7597 Indexing: disabled
2013-04-27 16:50:19.7647 Loading content types...
2013-04-27 16:50:19.7867 ._ADFolderCtd.xml ...
2013-04-27 16:50:20.1127 ========================================
2013-04-27 16:50:20.1137 Import ends with error:
2013-04-27 16:50:20.1187 ========== Exception:
2013-04-27 16:50:20.1197 XmlException: Root element is missing.
2013-04-27 16:50:20.3526 at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XPath.XPathDocument.LoadFromReader(XmlReader reader, XmlSpace space)
at System.Xml.XPath.XPathDocument..ctor(TextReader textReader)
at SenseNet.ContentRepository.Schema.ContentTypeInstaller.AddContentType(String contentTypeDefinitionXml) in C:\senseNet\Source\SenseNet\ContentRepository\Schema\ContentTypeInstaller.cs:line 60
at SenseNet.ContentRepository.Schema.ContentTypeInstaller.AddContentType(Stream contentTypeDefinitionXml) in C:\senseNet\Source\SenseNet\ContentRepository\Schema\ContentTypeInstaller.cs:line 56
at SenseNet.Tools.ContentImporter.ImporterClass.InstallContentTypeDefinitions(String ctdPath) in C:\senseNet\Source\SenseNet\Tools\Import\ImporterClass.cs:line 274
at SenseNet.Tools.ContentImporter.ImporterClass.Run(String ctdPath, String asmPath, String fsPath, String repositoryPath, Boolean validate) in C:\senseNet\Source\SenseNet\Tools\Import\ImporterClass.cs:line 168
at SenseNet.Tools.ContentImporter.Importer.Main(String[] args) in C:\senseNet\Source\SenseNet\Tools\Import\Importer.cs:line 176
2013-04-27 16:50:20.3606 =====================
2013-04-27 16:50:20.3626 ========================================
2013-04-27 16:50:20.3636 Import is finished with 1 errors.


What did I do wrong?
Thanks
May 8, 2013 at 1:08 PM
Hi, sorry for the late reply. It seems that something is wrong with the xmls.
Can you please check that the content type definition xml files are there in the right place, and look like normal xml files?

In the unpacked folder:
..\Source\SenseNet\WebSite\Root\System\Schema\ContentTypes